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1. Welcome

Welcome to Calizo, or better the documentation for Calizo. This documentation is
for Calizo version 0.2.5.

This documentation is still in a very early stage, but provides a good starting
point to get acquainted with the features Calizo provides.

Calizo is a time line calendar which allows zooming from small time scales like
hours, and days, to weeks, months years, and even beyond, to decades and centuries.
It uses the standard ical format. It provides direct links from events to files and
folders on your computer, as well as links to web content. Thereby, you can not only
manage scheduling tasks, but also use temporal order to organise your documents.

1.1 About
Calizo is open source software, licensed under the GPL 2.0, and is hosted at Source-
forge.net. It is programmed using wxWidgets, a open source cross platform frame-
work. Therefore Calizo runs on Linux, Windows and Mac.
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2. Installation

2.1 Windows
Since version 0.1.2 Calizo provides an installer, which makes installation very simple.
Download the installer from http://calizo.sourceforge.net, and run it. You may want
to associate Calizo with ical files, if you plan to open these files mainly with Calizo.
Otherwise the default options should be fine.

To build Calizo on Windows from source, you should get MinGW and MSYS.
Afer installing wxWidgets with the unicode option, you should be able to use the
automake facilities provided by MSYS (see 2.4). An alternative to automake is to
use the provided project files for CodeBlocks, a nice cross-platform IDE.

2.2 Linux
Currently Calizo provides deb files created on Ubuntu, using Version 8.10. Simply
download the deb file provided on http://calizo.sourceforge.net, and double click to
start the installation.

For Linux distributions not able to use the deb file, you may have to compile
Calizo from source. This should be straight forward as automake is used (see 2.4).
Alternatively you can also use CodeBlocks, for which project files are also provided
with the source package. You need to have wxWidgets developer packages installed,
or compiled by yourself.

2.3 Mac
As I currently have no continious access to a Macintosh computer, I am not able
to always provide binaries for OSX. You may want to try to compile Calizo from
source (see 2.4), whereas you have to make sure wxWidgets is also installed. You
have to install wxWidgets with unicode support.

2.4 Build from source code using automake
To build Calizo from source is simple as long as your system has a compiler, the
automake tools and the widgets library with sources installed:

• sh ./autogen.sh

• ./configure

• ./make
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3. History

Calizo got its name out of a discussion with Florian Grond. I am happy that he
suggested this Spanish family name with a nice sound. But if you want to have some
meaning in it, CALendar with Imense ZOoming capabilities is an option, another
one would be CALendar for Ical files with a ZOomable time line.

3.1 Change Log
Calizo-0.2.5 (2008-12-30):
- multiple selection of events by dragging a rect (while holding ctrl)
- translate multiple events (by selecting and holding ctrl while moving)
- tooltip when mouse hovers tail
- selection by click on tail
- report generation renewed

Calizo-0.2.4 (2008-10-18):
- fixed a bug hindering deletion of events

Calizo-0.2.3 (2008-10-04):
- nonlinear mapping slider in toolbar
- colour and font pickers in options dialog

Calizo-0.2.2 (2008-06-19):
- Code redesign
- Minor performance improvements

Calizo-0.2.1 (2008-04-06):
- Toolbar added
- Context menu on timeline background added
- Context menus updated

Calizo-0.2.0 (2008-02-15):
- Code redesign for performance and clean up
- Linux performance boost from code redesign
- Events can be moved (translated horizontally) now
- Drop ics files on background to load

Calizo-0.1.6 (2008-01-17):
- Generate HTML or text report for selected events
- Multiple selection for Linux and Windows working

Calizo-0.1.5 (2008-01-05):
- Documentation included (online and pdf)
- Performance improvements

Calizo-0.1.4 (2007-12-22):
- Complete Russian translation
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Calizo-0.1.3 (2007-12-17):
- Multiple selection of events (currently windows only)
- More complete translation for German
- Installer with option for file associations
- Calendar bar colouring in windows impreoved
- Icon for windows improved
- Uninstall in ‘Software’ listed (windows)

Calizo-0.1.2 (2007-12-10):
- Windows Installer

Calizo-0.1.1 (2007-11-30):
- calizo recognizes the systems language settings
- calizo tries to load the calizo.mo translation if available

Calizo-0.1.0 (2007-10-21):
- non-linear mapping of the time line
- event may or may not be separated by calendars
- copy and paste across applications (e.g. to sunbird)
- events can have descriptions
- gedcom import
- allowing events starting even before year -4800

Calizo-0.0.10 (2007-06-25):
- support relative links (relative to ics file path)
- relative links default for drag and drop
- selecting events also selects their calendar
- labels on dark events are drawn in white
- several bug fixes

Calizo-0.0.9 (2007-05-29):
- improved ical support
- reorganized drawing code to work on Linux
- faster drawing for large calendar collections
- title editing using F2 improved

Calizo-0.0.8 (2006-12-13):
- ‘tails’ showing event names for short events
- import calendar(s) of a document
- show target date when resizing an event
- cleaner drawing of event labels
- many bugfixes and performance improvements

Calizo-0.0.7 (2006-11-20):
- Options dialog (drawstyle customization)
- Jump to date dialog
- Automatic warning when saving non-calizo ical file
- Follow link by double, middle or ctrl+normal click
- Improvements in showing labels and date in zoomed in view
- Calendars inserted after selected calendar

Calizo-0.0.6 (2006-11-05):
- multiple calendars
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- standard view for document
- shortcuts for zoom, move, jump to today/this month...
- scroll window if many events are shown
- toggle tooltips
- statusbar with event information
- calendar colours, names and show/hide buttons
- reordering of calendars
- adding events by shortcut also, not only by mouse
- smoother/coarser zooming by mousewheel (+Ctrl or +Shift)
- many smaller changes...

Cailzo-0.0.5 (2006-08-14):
- Right mouse dragging to add new event
- Direct manipulation for resizing events
- Enter on active event to change title
- Links to local folders and urls supported!
- Drag and drop files and folders to create links
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4. Getting Started

As a quick start run Calizo and play around. Here some hints:

• Use mouse wheel to zoom, hold down shift/ctrl for finer/coarser zoom.

• Use right mouse button dragging to add events.

• Files and folders can also be dropped on an event to link.

• Use double click or SHIFT + CTRL + left click on events to follow links.

4.1 File format
Calizo uses the standard ical file format. The only thing that may be special is that
several calendars may be stored in one ics file.

WARNING: Calizo only writes to files what it understood!

So be very careful when importing iCal files, to overwrite them only if you have a
backup! Otherwise all other data in the file will be lost, like for example todos,
journal entries, and further event data like status, alarms, etc.

MAKE BACKUPS AND COPYS!
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5. Working with the time line

5.1 Basic navigation
To zoom the time line in and out, the best way is to use the mouse wheel. You will
notice that the location of the mouse pointer will determine the location where the
time line zooms in/out, that is, by using the mouse wheel you have a combination
of translation and zooming.

If you have no mouse wheel or prefer other ways there are two kinds of keyboard
navigation:

• ‘gamers choice’: ALT+w, ALT+s to zoom in/out, ALT+a, ALT+d to trans-
late left/right

• ‘standard arrows’: Arrow keys to zoom in/out with up/down, left right with
respective keys

In either case, holding SHIFT while zooming or translating will snap your navigation
to years,months,etc.

5.2 Extended navigation
When zooming with the mouse wheel, there are some special keys that modify the
behaviour:

• SHIFT will give you a finer granularity in zooming

• CTRL will give you a coarser granularity in zooming

• ALT+CTRL will translate the time line instead of zoom it

• SHIFT+CTRL will translate the time line vertically if your events are more
than can be displayed in current window size

With keyboard you can also use SHIFT+CTRL plus arrow up/down or page
up/down to translate the time line vertically if your events are more than can be
displayed in current window size (scroll window).
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6. Working with the event bars

By left clicking a bar you can select it (it will be displayed in a slightly lighter
colour). To select multiple events, hold down SHIFT or CTRL while selecting a
bar. You may also want to hold CTRL and drag a rectangle on the display to select
all events contained in the rectangle. Right clicking a bar will show a context menu.

To change an event bars start or end, use left mouse button. Navigate to the left
or right end, see the mouse cursor change to arrows, hold down left mouse button
and move the mouse.

To change an event bars start and end at the same time, that is to translate or
move it in time, hold down middle mouse button anywhere on the event and move
the mouse.

To change a bars title, either use the event edit dialog (menu or context menu),
or select the event and press F2, or hold down ALT while left clicking on the event.

If you provide a description for an event in the event edit dialog, you will also see
this description when your mouse moves on the event if you enable tooltips (from
menu View → Event tooltips.

A bar can provide a link to a file, folder or url. This can be edited in the
event edit dialog, accessible by menu or context menu (right mouse button). You
can also drag a file or folder on the event bar. If you have saved the file already
and drop a file path below the saved file’s path, a relative link will be generated.
Calizo uses ‘./’ as the folder where the ics file is located. ‘˜/’ on any platform (also
Windows) will be the users home directory. You can also provide links in the form
of ‘http://’, which will be opened by your default web browser if you follow the
link. The link can be followed or opened by menu, context menu, double click, or
hold SHIFT+CTRL while left clicking on the event.
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7. Working with the calendar list

To see the calendar list, you may have to select View → Calendar list from the
menu. Each calendar can have a different colour. You can add a calendar by Edit
→ Add calendar. you can toggle the current selected calendar by the page up and
page down keys. Calendars may be visible or not. This can be toggled also with
the shortcut key F3. You can change the order in which the calendars appear by
menu or shortcut key SHIFT + page up/down.

Calizo differs from other calendar applications with respect to multiple calen-
dars: Calizo saves all your calendars into on ical file. For exchange of calendars with
other applications, you may have to put all events into one calendar and remove
other calendars, which means that you should save your data into separate files,
each containing only one calendar.
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8. How To

8.1 Navigate
Its easiest to navigate Calizo by a mouse with a mouse wheel.

• use the mouse wheel to zoom in and out (and hold down shift or CTRL for
finer or coarser zoom)

• hold down left mouse button on the time line background and move mouse
left and right to shift the time line

Alternatively you may want to use the keyboard shortcuts:

• use arrow keys (and hold down shift for larger steps

• use ALT + W,A,S, or D (for left hand navigation)

8.2 Jump to a specific date
To move to a specific date pick Extras → JumpTo (or hit Ctrl+G). A dialog pops
up with a short documentation. Lets say you are at the position 27.12.2007 zoomed
to one month (hit Alt+t e.g.) and want to jump to 600 BCE zoomed to century
view. Then you simply enter ‘-600c’.

8.3 Add and change events
Calizo allows to add events by

• right mouse button dragging on the time line

• selecting add event from the menu (or via short-cut)

Changing events may be done by

• grabing the left or right border of an event to change start end end time

• selecting the event and pressing F2 to change the event title

• selecting the event and choosing edit event from the menu

• using right mouse button on the event to open the context menu and then
choose edit event

• changing an event link can be done by drag and drop of a file or folder on an
event

8.4 Use event links
• Changing an event link can be done by drag and drop of a file or folder on an

event

• Links to files or folders can be used as relative links, relative to the storage
location of the ics file (thereby ˜/ is the home directory, also on windows
machines)

• To follow a link, double click or hold SHIFT+CTRL while left clicking on an
event

11



8.5 Set a standard view for a document
A standard view may be stored for your document by

1. zooming and shifting the time line to a specific view

2. selecting View → Standard → Set-current from the menu

If you now save the document and reload it, the timeline will start with the
specified view. You can also always jump to the specified view using menu View →
Jump-to → Standard or using the shortcut Alt-Y

To change the standard view simply chose a new one by selecting View →
Standard → Set-current again To remove the stored view select View → Standard
→ Clear

8.6 Generate a report
You can generate a report including title, start, end, and description of events for
selected events:

1. Select multiple events by holding SHIFT or CTRL while clicking on several
events. These events may also stem from different calendars.

2. Select from menu Extras → Report.

3. A report is shown in HTML view.

4. To save the report use one of the buttons. Save as text will generate plain
text, save as html will generate a HTML file using UTF-8 encoding.
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9. Known Problems

9.1 Edit dialog doesn’t handle BCE dates
The current event-edit dialog is not able to edit BCE dates (to be more exact even
dates before 1752 can not be entered). This is a todo on my list, but needs an
expansion of the standard date widget of wxwidgets. To ‘enter’ BCE events, the
only way currently is not to use the edit dialog, but use right mouse button drag
to create an event (zoom to 400 BCE, and drag an event by right mouse button
into the view. Correct the start and end date by left mouse button dragging of the
border. The exact date is shown in the status line while dragging to allow better
adjustment). The only other way to really enter dates BCE is to use an simple
editor and go for the ics file directly.
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10. Help Wanted

Developers wanting to join the project are very welcome! Also for the documenta-
tion, I would be glad to find someone willing to participate. If you want to provide
a translations for an additional languages don’t hesitate!

10.1 Credits
Programming and German translation by Sebastian Fischer.
Russian translation by Ivan Belousov.
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